Page 4 of 4 FirstFirst ... 234
Results 61 to 77 of 77

Thread: ChrisFBartlett 4-door 58 Belvedere

  1. #61
    ICC MEMBER big m's Avatar
    Join Date
    May 2005
    Location
    Williams, Ca.
    Posts
    5,916
    Glad to see she's rolling again!!!

    --John
    Big M Auto-

    "We buy junk, and sell antiques"
    ICC member since just after dirt, but before baseball.

  2. #62
    Moderator Imperial King's Avatar
    Join Date
    Jul 2010
    Location
    United States of America
    Posts
    8,847
    Good news Chris. Please keep the updates coming here.
    Go outside and enjoy life.

  3. #63
    Love that pic! I always think these cars look so sinister if you get the angle/lighting right, especially with the lights on hi-beam.
    1958 Plymouth Belvedere 2 dr ht (under restoration)

    ROCK AND ROLL WILL NEVER DIE

  4. #64
    Yes, very happy to have her on the road.... for a week. I broke a push rod and one of the valves stuck open. It still drove but sounded very rough and very little power. We are pulling all the rods and replacing with new ones. Should be back on the road this weekend. In the meantime. More pics of her maiden voyage in Hollywood!




  5. #65
    Moderator Imperial King's Avatar
    Join Date
    Jul 2010
    Location
    United States of America
    Posts
    8,847
    Nice pictures Chris. As far as the situation with the push rods and vlave becoming stuck open, were you able to coax the valve shut or is it still open?
    Go outside and enjoy life.

  6. #66
    Sorry it wasn’t stuck open, it just wouldn’t close because the rod broke. I got a new set of push rods and it runs better than ever!

  7. #67
    ICC member 57belv's Avatar
    Join Date
    Jun 2014
    Location
    Minnesota, U.S.A.
    Posts
    1,195
    Good you got her fixed up! Never heard of a push rod actually breaking before, only bending.

  8. #68
    Moderator Imperial King's Avatar
    Join Date
    Jul 2010
    Location
    United States of America
    Posts
    8,847
    I'm happy for you Chris. Please keep the updates coming!
    Go outside and enjoy life.

  9. #69
    Moderator Imperial King's Avatar
    Join Date
    Jul 2010
    Location
    United States of America
    Posts
    8,847
    If in the future, the rockers become noisey, the Lash adjustment for 1960 318 is .010 hot for intake and .018 hot for exhaust.
    Go outside and enjoy life.

  10. #70
    Quote Originally Posted by Imperial King View Post
    If in the future, the rockers become noisey, the Lash adjustment for 1960 318 is .010 hot for intake and .018 hot for exhaust.
    Ah, thank you very much!!

    Current issue: Transmission won't shift into reverse or overdrive (? the freeway gear?) until the transmission is hot - as in, been driving for several miles. Makes me worry about freeway driving in this condition. Fluid is clear & full (at idle).

    Any ideas what might be wrong?

  11. #71
    New Whitewalls mounted! Link here>> F78-14 from Coker with the 2 3/8 inch whitewall

    Last edited by ChrisFBartlett; 05-27-2020 at 07:03 PM.

  12. #72
    ICC member 57belv's Avatar
    Join Date
    Jun 2014
    Location
    Minnesota, U.S.A.
    Posts
    1,195
    Oooo! Beautiful! Cokers?

  13. #73
    Quote Originally Posted by 57belv View Post
    Oooo! Beautiful! Cokers?
    Yes thanks! F78-14 Coker, 2 3/8" whitewalls

  14. #74
    Moderator Imperial King's Avatar
    Join Date
    Jul 2010
    Location
    United States of America
    Posts
    8,847
    Quote Originally Posted by ChrisFBartlett View Post
    Ah, thank you very much!!

    Current issue: Transmission won't shift into reverse or overdrive (? the freeway gear?) until the transmission is hot - as in, been driving for several miles. Makes me worry about freeway driving in this condition. Fluid is clear & full (at idle).

    Any ideas what might be wrong?
    Hey Chris,
    I read your posts. The tires look nice on the car. The transmission concern you have is a interesting. To properly diagnose the concern, I would have to physically do testing and eyeball things.
    What popped up in my head was the fluid. You mentioned, it was clear and full. That's good. However, if I remember right, the car sat for an extended period of time. Was the transmission ever serviced or if it was when? I'm wondering if there maybe a concern in the valve body and possible sticking spool valves,apply piston, etc.. You also mentioned that you replaced the engine. Is the shift linkage adjusted properly where it meets the carburetor?
    Now what you can try to do is replace the transmission fluid with Dexron/ Mercon III, note if there is a lot of shavings in the pan. (Shavings in large amounts might mean a rebuild) If you have a service manual, make sure the shift linkage is adjusted properly.
    Again, I can advise you from a distance. It's far better to actually do physical testing in person.
    (Just a note: Cast iron torqueflite does not have overdrive. 3 forward speeds, neutral and reverse)
    Last edited by Imperial King; 05-27-2020 at 06:37 PM.
    Go outside and enjoy life.

  15. #75
    Imperial King, thank you very much for this! Yes, the linkage was adjusted up when the engine was installed, but the transmission wasn't rebuilt, just hooked up. I'll check with my shop on the linkage and may switch out the transmission fluid to check for shavings too.

  16. #76
    Moderator Imperial King's Avatar
    Join Date
    Jul 2010
    Location
    United States of America
    Posts
    8,847
    Quote Originally Posted by ChrisFBartlett View Post
    Imperial King, thank you very much for this! Yes, the linkage was adjusted up when the engine was installed, but the transmission wasn't rebuilt, just hooked up. I'll check with my shop on the linkage and may switch out the transmission fluid to check for shavings too.
    Good Chris. Please let us know what happens.
    Go outside and enjoy life.

  17. #77
    I see dead people! Doobster's Avatar
    Join Date
    Sep 2007
    Location
    England
    Posts
    11,564
    Chris, when you get the chance, could you do me a favour and take a photo of the front view of your car please?

    My Christine has Coker Bias/plys but they don't quite feel right when driving.

    I think my tires also look too thin in comparison to Christine on the movie so at some point I'd like to rectify that and your tires could possibly help me as a reference (I'm not sure if I'd need wider wheels than I have for a wider tire and am not sure how wide my existing whitewalls are).

    Thanks mate.

    Lee.
    UK.
    Everything's good!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •